Working with Audio
Applications

Flash MX is one of the main applications of choice for showcasing
bands and their music. You can find audio players, turntables,
and interactive mixing boards created in Flash all over the Web.
There is a behind-the-scenes process that involves various audio
applications to capture and edit audio in a digital environment.
Creating and editing your own sound will give you a unique and fresh
approach to your projects. With audio-editing software, you might
find that you gain some insight into the music world, even if you can’t
play an instrument!

In this chapter, you'll learn how to prepare multimedia sounds for use
in Flash. Because of the limited number of options for editing audio in
Flash, we recommend that you optimize and experiment with sound
clips in an external application before importing them into the
Library. When creating or editing audio for use in Flash, we cannot
stress enough the importance of starting out with the highest sample
and bit conversion rates possible. Remember that sound quality, in
general, is simple to degrade but can be difficult or impossible to
restore, so it’s not a good idea to skimp from the beginning. Ideally,
your original files are 16-bit 44.1 kHz stereo. From this point on, we
assume that your audio clips are of reasonable quality and were cap-
tured or created from a good 16-bit source, such as an audio CD or a
sound effects application, such as Propellerhead’s Rebirth (which is
discussed later in this chapter).

Sound-Editing and Creation Software

Just about every multimedia or video software package includes a
sound-editing application. For the most part, you'll find limited edi-
tion (a.k.a. LE) versions of popular sound applications bundled with
Macromedia Director or video application suites, such as Digital
Origin’s EditDV. For a price, you can upgrade these LE versions to full
versions, or purchase them separately if you don’t need or want a full
multimedia production software package. While very few of the fol-
lowing applications are available on both Macintosh and Windows
platforms, their functionality is virtually identical.

Several software companies produce excellent sound-editing soft-
ware. Many of these companies offer a software suite of their flagship
products bundled with several supporting products that specialize in
different areas of audio editing and creation. The following is a list of
some of the most popular software developers that offer audio cre-
ation and editing applications.
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You can perform the same basic functions described in this chapter in either the LE or fully
= featured versions of the sound-editing application. LE versions usually have less effects-
oriented controls, such as sound filters and enhanced noise reduction.

Sonic Foundry’s suite (PC only)

Sonic Foundry (www.sonicfoundry.com) provides the best-known sound-editing solutions
for the Windows operating system. From simple editing to powerful looping effects, Sonic
Foundry has a tool to work with any sound project.

Sound Forge

Sound Forge is a powerful, yet easy-to-use waveform sound editor for the PC environment. A
great feature of Sound Forge is nondestructive editing. Sound Forge can also be integrated
with Sonic Foundry’s ACID software.

Sound Forge supports all three of the Flash-compatible audio import formats, AIFF, WAV, and
MP3. In addition, it has the capability to save in the RealAudio G2 streaming format. You can
open an existing sound file, edit it, and save it as WAV, MP3, or AIFF with several different
options for sampling and bit rates.

ACID PRO

ACID is a powerful, loop-based sound-editing program that is ideal for use with Flash (see
Figure 39-1). With ACID, you can very easily take loops created in other programs and arrange
them on multiple tracks. One of the ACID program’s great features is its capability to change
the speed of the loop without changing the key. ACID PRO also comes with over 100 ready-to-
use loops, so you can arrange an audio track in a pinch.

Syntrillium Software

Syntrillium Software (www.syntrillium.com) creates sound-editing applications for the
Windows operating systems. Cool Edit 2000 offers an excellent alternative to Sound Forge as
does Cool Edit Pro for digital multi-tracking.

Cool Edit 2000

Cool Edit 2000 is a waveform editor that has many similarities to Sonic Foundry’s Sound
Forge. It allows you to edit and convert your audio samples as well as enhance them with spe-
cial effects, such as reverb, delay, chorus and many others. Cool Edit 2000 supports all three
of the Flash-compatible audio import formats, AIFF, WAV, and MP3.1t also has the capability to
save in the RealAudio G2 streaming format.

Cool Edit Pro

Cool Edit Pro is a complete multitrack recording studio with up to 128 stereo tracks to record
with. Utilizing multiple editing and mixing windows, you can also take advantage of real time
effects and looping tools. Other features include MIDI playback support, CD ripping, and cus-
tomizable interface configurations. Cool Edit Pro supports all three of the Flash-compatible
audio import formats, AIFF, WAV, and MP3.
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Figure 39-1: In ACID, you can very easily preview an audio clip, add it as a track, and
move it around a timeline.

Bias suite (Mac only)

Bias (www.bias-inc.com) creates sound-editing applications for the Macintosh operating
system. When Macromedia stopped developing SoundEdit 16 Deck, Bias picked up the prod-
ucts and started to fine-tune them for new Web technologies.

Peak

Peak is the tool for getting down and dirty with editing stereo tracks. It supports a large
number of file formats and nondestructive editing. Some of the other features of Peak are
its capability to execute batch file processing, burn CDs directly from a playlist, and export
in RealAudio G2 streaming format. Peak is rapidly becoming one of the most widely used
audio-editing applications for multimedia on the Macintosh. It is available in both full and
LE versions.

Deck

Deck is a powerful nondestructive multitrack editor, for the Macintosh platform. In addition
to being capable of playing back up to 64 tracks simultaneously, Deck can also function as a
multitrack recorder, enabling you to create your own music or sound effects. It is less expen-
sive than other similar software packages, and can be closely integrated with Bias Peak.
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Cakewalk Pro suite (PC only)

Cakewalk (www.cakewalk.com) manufactures top-of-the-line audio software for the sound
professional. The company’s software is designed for serious users who need to master audio
for broadcast and CD applications.

Sonar is a powerful multitrack editor and MIDI sequencer for the Windows platform. Sonar
allows unlimited potential tracks, has an unlimited undo and redo history, and comes
equipped with real-time effects. These features make this software an excellent option to
Pro Tools and Cool Edit Pro.

Studio Vision Pro (Mac only)

Studio Vision Pro (www.opcode.com) is probably the best deal out there for anyone on a tight
budget but who needs all the advanced features from the more expensive programs. Studio
Vision Pro is a multitrack editor/recorder with the capability to work with MIDI information
and digital audio.

Cubase (Mac/PC)

Cubase (www.us.steinberg.net) is one of the very few programs available on both plat-
forms. Cubase is a top-of-the-line multitrack editor/recorder. Cubase has the capability to
edit and print musical scores and to handle both MIDI and digital audio. It is capable of
16- to 24-bit audio and has a built-in virtual synthesizer.

Macromedia SoundEdit 16 (Mac only)

SoundEdit has had a relatively long history with Macintosh users as a sound-editing work-
horse, especially for use with multimedia. Although still widely used, SoundEdit 16 is no
longer being produced by Macromedia, and Mac users are slowly migrating to the more-
robust, full-featured Peak.

Digidesign’s Pro Tools (Mac/PC)

Last, but not least, is Pro Tools (www.protools.com), the industry standard. If we were to
walk into just about any major recording studio, we would see Pro Tools displayed on their
massive monitors. Naturally, the professionals will have more than just Pro Tools on their sys-
tem. In fact, the audio engineers will usually have several of the programs mentioned earlier
because they might require a feature or two that only another program supports. (In the
same way that Flash can’t do everything we want, so we use other programs to help get some
effects.) But in the end, the reality is that the Pro Tools system is the primary professional
tool for audio editing and mixing.

Not only do the makers of Pro Tools make software products, but they also make some of the
hardware for sound studios, including computer peripherals. Once you bring hardware into
the equation for setting up a system, the cost can go sky-high. Thankfully, Digidesign is aware
of this fact and has developed two home studio kits for all those people who love to make
music but don’t have a major studio budget or a degree in audio engineering.

The four main systems in the Pro Tools shop are the Pro Tools HD, Pro tools 24MIX, Digi 001,
and the Mbox. The HD and 24MIX are high-end systems (beyond the scope of this chapter).
The Digi 001 and Mbox are very keen units. The Mbox is a stand-alone unit with two analog
inputs and outputs, 24-bit stereo S/PDIF digital I/0, and built in mic preamps. This system is
currently supported by Mac only, although a Windows version is on the way. The Digi 001 is a
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step up from the Mbox, with up to 18 inputs and outputs combined. Both units utilize Pro
Tools LE software to organize and mix tracks. LE software gives you 24 audio tracks, 128 MIDI
tracks, and editing and sequencing power. These units are perfect for anyone considering tak-
ing their recording to the next level.

Capturing Your Own Sound: Building Your Own
Recording Studio

All the situations mentioned in this chapter assume that you already have digital audio files
to work with. However, you might want to create some custom sound effects, voice-overs, or
original music for your Flash movies. Let’s take a brief look into what it takes to build your
own home recording studio.

Instrument of choice

The first step in organizing your audio tools is asking yourself what type of audio you want to
bring into the digital world. Whether you have a keyboard, guitar, drum set, or microphone,
you'll need to capture that audio and digitize it to use in an audio application. The quality of
your sound starts here, and certain mistakes in this step can ultimately ruin the final sound
quality. Microphone position, quality instruments, and preamps all play an integral role in
this process. If you're interested in taking sound recording to a more advanced level, it is
worth seeking out some of the excellent books available specifically on this topic.

Choosing a sound card

Although some audio applications allow you to edit audio without a sound card, most com-
puters come with a sound card preinstalled. You will have to determine if that card is suffi-
cient to meet your audio requirements. Certain audio applications require a higher level of
card (or even preamps and processors) to bring music to line level. You will have to evaluate
the software requirements of the editing program that you choose as well as your own audio
needs to determine if an upgrade from your existing sound card is necessary. One of the most
important things to look for in a sound card is the bit rate —anywhere between 16 and 24 bit
is acceptable. A standard audio CD is recorded at 16-bit, 44.1 kHz, stereo. The next feature to
look for is the number of input and output modules. If you need to record more than one
instrument at a time (or if you choose to record in stereo), you will need two or more inputs.
Your output modules are important for playing back audio on a designated set of speakers.
Another feature to look for is Digital Ins/Outs to hook up CD, DAT, and other digital players
that have a coaxial output. Since most sound cards are compatible with a variety of audio
applications, you have the option to shop for your own or purchase the specific card sug-
gested by your preferred editing application.

Getting your sound in

Now that you’ve picked some type of instrument and have a sound card to digitize your audio,
you need to prepare the sound for entry into the digital world. Depending on your equipment,
you may not be able to plug your instruments directly into the sound card. If this is the case,
your audio will need some sort of preamp to bring the signal up to an adequate level. Some
sound cards do come with a built in preamp. But you also have the option to purchase an
external unit with a built in preamp for the inputs, such as the Digi 001. Most amplifiers have
a direct out, however your microphones and synthesizers need an external preamp. Your
options are to purchase a mixing console with built in preamps or to purchase individual
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preamp units. Such units can run from under $100 into the thousands. This is an important
step that you will get better at with experience. Don’t be afraid to experiment with different
preamp settings, microphone placements, and individual volume settings on your instru-
ments to achieve the custom sound that you desire.

Getting your sound out

After you record your sound, you need to preview the digitized audio to ensure that your
instruments, preamps, and sound card/computer are all working together. Your sound card
will have some sort of output port, which can connect to an external set of speakers. You will
often have the option to run the instrument internally through your computer directly out to
your speakers. This step is important because it lets you check the digitized sound against
the original sound of the instrument. This method also allows you to adjust your equipment
to achieve a particular sound and even create presets to save time in setting up frequently
used instruments.

Conclusion

Just remember to keep it simple at first. Learn and purchase enough to get started. You can
always expand and add new equipment and hardware to your collection. If you start to get
more involved, you might want to have a computer solely for audio purposes. You will need a
processor that can handle streaming audio as well as the hard drive space to store it all.

Basic Functions of Audio Editing

The editing features of audio applications can range from basic to extremely advanced; many
go well beyond the audio needs of most common users. In this section, we will discuss some
common editing features, from basic to more advanced.

Making your audio selection

First, you will have to choose which portion of audio you want to use in your Flash applica-
tion. Each audio clip has a cursor point that designates the point at which the audio will start
playing or the selection will begin. You can change the location of this point by clicking your
mouse at any position in the audio timeline. The cursor point also designates where your
copying, or cutting and pasting, begin. Clicking and dragging your mouse from one point to
another will highlight a particular section of the audio. You can now copy or cut this selection
from the edit menu. Let’s apply these methods in a real production situation.

Setting In and Out points

One of the first things you do with an audio file before bringing it into the Flash environment
is set its In and Out points. These points, respectively, control where the sound will start and
end. Removing any unwanted sound (or dead space), at the beginning and end of each audio
file will help keep your audio in perfect synch with animations and loops. This also helps to
minimize the sound’s file size (see Figure 39-2), making it less cumbersome to move around
and reducing the amount of time that you’ll have to spend adjusting the sound in Flash. You
can set In and Out points in most, if not all, audio applications.
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Figure 39-2: You can greatly reduce the file size of a Flash movie by limiting audio
tracks to essential portions.

In Sound Forge, Peak, and SoundEdit 16, follow these steps to set the In and Out points of a
sound:

1. Highlight the area you want to keep.

2. Test your selection by pressing the Play Loop or Play button (Sound Forge).
To create a new audio file with your selection:

1. Select File> Copy (Ctrl+C or 88+C).

2. Select Filew> New (Ctrl+N or 8+N).

3. A new window opens. Select Edit=> Paste (Ctrl+V or 8+V).

4. Your selection will now be a new audio file, containing only the part of the sound that
you want to use.

Fade in and fade out

As discussed in Chapter 15, “Adding Sound,” fading in means increasing the volume of a
sound over time, and fading out means decreasing it. Most audio-editing applications have
more sophisticated fading effects than Flash.

To fade audio in Sound Forge:
1. Select the part of the audio that you want to fade in or out.
2. Choose Process = Fade = Graphic.
3. The Graphic Fade Window appears (see Figure 39-3).

You should now see your selected sound as a waveform (that is, a graphic representation of
sound waves). The interface for customizing your fade is similar to the one used in Flash. You
create envelope handles by clicking points on the envelope line at the top of the waveform.
Drag these handles around to create your desired volume/fading effects. The lines themselves
show the volume level of the sound. Thus, when you drag an envelope handle down, the line
slopes down, indicating a decrease in the volume level. Click Preview to hear your custom
fade. Click OK when you are satisfied.
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Figure 39-3: Sound Forge enables you to save custom
fade effects to apply to other sounds.
To fade audio with Peak, follow these steps:
1. Select the section of audio that you want to fade in or out.

2. Choose Preferences = Fade In Envelope or Fade Out Envelope. The Fade In Envelope or
Fade Out Envelope Window appears.

3. You can use the default fade shape or create your own by using a similar technique to
the one described previously for Sound Forge.

4. Choose DSP = Fade Out. Peak will apply the fade to your selection.
5. To hear your Fade, press Option+spacebar.
To fade audio with SoundEdit, follow these steps:
1. Select the section of audio that you want to fade in or out.
2. Choose Effects > Fade In or Effects => Fade Out.

3. Create your fade using a similar technique to the one described for Sound Forge.
SoundEdit also has Slow, Medium, or Fast fade presets. Click OK when finished.

Normalizing Audio Levels

Tip

Normalizing is a process applied to audio to gain equilibrium in the overall sound level. This
function allows you to put a cap on how high the audio level can go to prevent clipping.
Digital clipping occurs when audio is recorded at too high a level. When the upper levels of
the sound are above the range of the recording or playback device, parts of the sound are
clipped or distorted, resulting in an undesirable crackling or buzzing sound. The Normalize
option is available in most audio applications and can also be used to boost levels when your
audio file was recorded too low.

If you're gathering sound samples from a number of different audio sources (such as audio
CD, direct recordings with a computer microphone, DAT recordings, DV camcorder audio,
# and so on), it's best to normalize all of them to a consistent audio level.
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To normalize in Sound Forge, follow these steps:
1. Select a specific part or all of the clip to be normalized.
2. Choose Process = Normalize.

3. The Normalize window appears (see Figure 39-4). You can click Preview to see how the
default settings will affect your sound levels.
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Figure 39-4: The Sound Forge Normalize window
enables you to preview settings before you apply them
to the audio clip.

Watch the Play Meter on the right side of the screen. If the levels seem high (constantly in the
red), lower the levels with the slider bar on the left side of the Normalize dialog box. If your
levels are too low, gradually raise the slider bar. Click OK, and your file will be normalized to
the levels you have selected. Note that many other options exist in the Normalize Window;
experiment with these settings to get the result you're looking for.

To normalize in Peak and SoundEdit, follow these steps:
1. Select part or all of the clip to be normalized.
2. In Peak, choose DSP > Normalize; in SoundEdit, choose Effects &> Normalize.

In Peak’s Normalize dialog box, you can move the slider bar back and forth to choose the nor-
malization percentage. The number you choose will normalize the sound to a percentage of
the maximum level. After you click OK, you can listen to the normalized selection by pressing
Option+spacebar. Watch the levels for any clipping. The next section will go into more detail
on normalizing and optimizing audio.

Caution If you're recording sounds with a microphone attached to your computer's sound card, make
sure that you have adjusted the microphone’s volume level (or gain) in the sound-recording
application. If the levels are too high during recording, you won't be able to normalize the
sound —the resulting sound will be very distorted and “clip” on playback.
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Optimizing Sound for Flash in Sound Forge

While we already explained how to perform basic normalization on sound files, we will now
explain how and why to optimize sound levels and sampling within Sound Forge. Most of the
sound-editing applications we mentioned earlier can perform similar operations as well. Refer
to your sound-editing software manual for the specific menu commands that are necessary
for normalization and sampling rate.

In a perfect Web world, we would be using stereo files at their highest sample rate. As the cre-
ator, you must decide which is more important: download time or sound quality. The settings
discussed in this section can be used to decrease file size while maintaining decent sound
quality. However, if your original sample sounds bad, these settings will make it sound worse.
A little bit of sound advice: Bad in = Bad out!

Although it is true that MP3 offers the best sound compression, for ideal results it helps to
know a few tricks that will enable you to reduce the file size before importing sounds into
Flash — this will result in even smaller sound files with better sound quality. Another bit of
sound advice: Smart sound = Better, smaller sound.

Although a number of excellent programs may be used for sound editing, we will use Sonic
Foundry’s Sound Forge to explain normalizing and resampling.

Normalizing a sound file

Normalizing is used to increase the volume of a sound file without fear of clipping. You can
also set specific parameters so that certain areas can be ignored or intensified. Start by
opening your sound file in Sound Forge. If you like, you can drag and drop the file right into
the workspace. Make sure that your file is completely deselected; then choose Process =
Normalize. This applies the normalization process to the whole file. Don’t be intimidated by
all the settings. Here is a walk-through of each control in the Normalize dialog box.

4 Normalize using Peak level or Average RMS: Choose Average RMS. This will enable
you to save a setting so that if you have more than one sound file, you can maintain
and compare volume between audio files.

4+ Normalize to: This sets the level of your normalized sound. A value of 16 to 20 percent
is a good starting point. These settings mean that the sound volume will be reduced by
a factor of 16 to 20 percent. Remember that when the final SWF is played, the Flash
player will boost your gain by several decibels.

4 Scan settings: The best feature of this is the Ignore below slider. This enables you to
choose a level at which the normalization will bypass. Simply put, you might have sec-
tions of silence in your file. If you boost the gain in these sections, you might bring out
unwanted frequencies (noise) that you couldn’t hear previously. After you've scanned a
selection, you can use the RMS calculations to gauge what level to set the slider at. In
most cases, anything under 5 percent is a good starting point. Be careful though! If your
file is already at a low decibel, these settings could bypass the whole normalization
process. If you're uncertain, leave the slider at 0 percent. You can leave the default set-
tings for attack and release time at 200 and leave the Use equal contour box checked.

4+ If clipping occurs: Select Apply dynamic compression. This is your safety net.
Although you may have a situation in which the normalization settings are exactly
where you need them to be, some sections may still peak. Applying dynamic compres-
sion prevents any peaks from exceeding the threshold.
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After you've set the parameters, you can audition (preview) your selection. If you're using
multiple audio files in a Flash project and want to maintain consistent volume throughout,
use the Save as button to save a preset for future use.

Resampling

Most of the audio files you work with are probably set to stereo 44.1 kHz. This may be fine for
CD-ROM applications, but the Web is a different area. If you plan to severely downgrade the
original sampling rate of a particular sound file in the final Flash movie (SWF file), we recom-
mend that you optimize your sound as mono 22.05 kHz before you import the file into Flash
MX. After the sound is in a Flash document, you can then continue to decrease the file size
with MP3 compression. A third-party sound editor, such as Sound Forge, gives you the advan-
tage of higher-quality filters and high-end processing. Although Flash can resample PCM files,
it will not process them with the same level of quality that a program such as Sound Forge
offers. Furthermore, Flash prevents you from resampling in MP3 format. Your ideal situation
is to resample while introducing as little audible change as possible. Again, your ear will be
the best judge.

,"'Note PCM stands for Pulse Code Modulation. It is a standard sound-sampling mechanism for
il audio —it is a digital representation of sound.

To begin resampling, with your sound open in Sound Forge, select Process > Resample. Then
make your choices from the settings that follow:

4+ New Sample Rate: Select a new sample rate from the New Sample Rate drop-down or
else type the rate into the field yourself. The next two items are the most important.
These filters maintain your sound quality.

4 Interpolation accuracy: This determines the range of number crunching or the com-
plexity of the calculations that will be used to resample the sound. A higher number
results in a more accurate resample calculation. A setting of 4 takes longer to process
than a setting of 1 but will come closer to your original sample. This setting will not
change your file size; it only affects the guality of the resample.

4 Antialias filter: When resampling sound, you might notice distortion or a loss in the
high end. Applying an antialias filter helps prevent these high frequencies from distort-
ing. Preview your sound and resample accordingly.

Final notes

You should always normalize your sound file before you resample, because this processing
order preserves the best sound quality. We recommend that you keep the Create Undo box
checked at all times, because this type of editing drastically alters your file, and it can be very
nice to have that Undo available. Similarly, it can be advantageous to use the Save as com-
mand (and save to a new name) after you have made your changes. This procedure preserves
the original file so that you can go back to it later.
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Optimizing a Sound File Step by Step

The following exercise demonstrates how to optimize the file size and type prior to importing
a sound to Flash. This example uses Sonic Foundry’s Sound Forge. You can also follow similar
steps with other audio editing applications. The order of the steps is important and should
be applied, regardless of what editing application you're working in. Other applications may
differ slightly from step to step, but the basic process remains the same.

1.

2.

~

Open the DB_Loop.wav file, located in the ch39 folder of the Flash MX Bible CD-ROM.
Note the file’s info at the bottom right hand of the application window (see Figure 39-5).

[ e T | Figure 39-5: The sound file’s information

. Select Filer> New (Ctrl+N) and choose settings to match the file info (shown in the pre-

vious step) for the sound that you want to edit (see Figure 39-6).

Figure 39-6: The New Window dialog box is used to
select settings for a new file.

Return to your source file (DB_Loop) and use Edit > Select All (Ctrl+A).

Go to your new sound file window and paste the source selection in. You can now close
the original DB_Loop.wav file.

Now, let’s increase the level of audio and cap the peaks so there is no clipping.

Select the new file, named sound2 by default. When no particular selection is high-
lighted, any process or effect you choose will be applied to the entire file.

Choose Process = Normalize. The Normalize dialog box appears. You can click Preview
to hear what your current settings are. We recommend -16.00 db as a starting point.
Note that the Apply dynamic compression option is selected in the If clipping occurs
field, as shown in Figure 39-7.

Figure 39-7: The Sound Forge Normalize
dialog box
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Now that you have the file levels set, you can start to optimize the file to a lower size.
Converting the file to Mono will cut the file size in half.

8. Choose Process = Channel Converter. The Channel Converter dialog box appears.
Choose Mono from the Output channels radio buttons. Lower the levels to 70% to
avoid clipping. See Figure 39-8 for these settings.

Figure 39-8: The Channel Converter
dialog box

The last step in the optimization process is to resample your loop. This step will make
noticeable changes to your sound quality. You can adjust this based upon the final
quality and file size that your project requires.

9. Choose Process > Resample. Select 22,050 from the New sample rate menu. Select 4
from the interpolation accuracy slider. Select the Apply an anti-alias filter during resam-
ple option. Refer to Figure 39-9. Click OK.

Figure 39-9: The Resample dialog box

10. Save your file. The sound is now ready to import into Flash.

You can use the MP3 settings in Flash to reduce the file size even more. Note the difference in
file size between the original file and your new file— 1,327 KB for the original and 332 KB for
the optimized!

There are many possible variations in these steps. The previous steps were merely recom-
mendations for the best optimization of file size while preserving sound quality. Each project
will dictate it’s own rules. Use your best judgment for file size and always use your ear. If it
sounds really bad . . . try a different approach!

1009
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Effects

Audio applications come with effects that can be applied and customized for enhancements
to your sounds. It is extremely important to know when to use effects and how they can work
together. Special effects can have compound results, depending on the order in which you
place them. Placing Reverb first and then Delay will sound different than the reverse order.
Many effects can also push your levels into the red zone and cause clipping. You may have a
selection normalized and ready to go and then decide to add a bit of reverb. This could cause
clipping that would require a customized setting in the effects window to correct. If you're
inexperienced, this may start to get confusing. Although many applications use nondestruc-
tive editing, there is often a specific order in which things can be removed. Say you cut,
paste, normalize, and add reverb to a selection of audio in that order. If you wish to remove
the normalization process you will have to remove the reverb first. For this reason, we highly
recommend normalization as a final step.

Creating a reverb effect

Adding reverb to a sound file can create an interesting effect. Reverb creates the auditory
illusion of acoustic space. For example, you could simulate the sound of water dripping in
a cave.

To add a reverb to an audio sample in Sound Forge, follow these steps:
1. Select the section of sound that you want to add reverb to.
2. Choose Effects = Reverb.
3. The Reverb dialog box appears.
4

. Select a Reverberation Mode from the drop-down menu. To create the dripping-water
sound, choose Cavernous Space.

5. Press the Preview Button to hear how the effect sounds. Play with some of the sliders
and other options until you achieve the desired effect. When done, click OK.

SoundEdit 16 has a similar effect to reverb called Echo. To add Echo to a selection, choose
Effects = Echo.

Creating your own custom sound effects.

You might have the need for a sound effect that you cannot find on a library disk or that you
don’t have a budget to pay for. This will give you the chance to get creative and make your
own sounds by utilizing everyday objects in conjunction with the effects processing available
in Sound Forge. The following exercise shows how to create an explosion effect by recording
a door closing. This example assumes that you already have access to a microphone and
sound card and that you're set up to record your own sounds.

Let’s add some space to the end of the file for the explosion effect:
1. Open the door.wav file, located in the ch32 folder of the Flash MX Bible CD-ROM.

2. You'll need to add some sound to the end of the file for the echo. Select Process =
Insert Silence. Set the menu to End of File and add 2 seconds in the time area, as shown
in Figure 39-10.
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Figure 39-10: The Insert Silence dialog box

Now let’s create an explosion.

3. Select the final portion of the sound waveform, as shown in Figure 39-11.

Figure 39-11: A selection from the sound file

4. Select Effect > Reverb. Choose the preset Cathedral from the Name menu at the top of
the dialog box. Adjust the Reverb out to -9.0dB. Adjust the Early Out slider to —-20.0.
Adjust the Decay time slider to 3.5 seconds. Adjust the Pre-delay to 55. When you're
finished, your settings should resemble those shown in Figure 39-12.

Figure 39-12: The Reverb dialog box

You can cut the opening of the door off or leave it on. That is up to you. This should give you
some other ideas on making you own sound effects. All you really need to get started is a
microphone and some imagination.
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Other effects

Many other effects and processes are available in these audio-editing applications, and to list
them all would be beyond the scope of this book. A great feature of many of these software
packages is nondestructive editing. You can make as many changes to your audio clips as you
like without destroying the original source files. Set aside some time to experiment and let
your creativity take over.

If you don’t have any source sound material for adding effects, you can create your own
super-synth techno music with Propellerhead’s Rebirth. The next tutorial by Justin Jamieson
shows you how to create a soundtrack with Rebirth.

Using Propellerhead’s Rebirth to Create Loops
for Flash, by Justin Jamieson

If you don't want to invest time and money in audio hardware, you can use Rebirth to cre-
ate electronic music. Justin’s tutorial walks you through the basic process of mixing samples
and beats in Rebirth.

Rebirth is an innovative sound-creation tool that accurately replicates vintage analog syn-
thesizers and drum machines. Simply put, it enables you to easily create electronic music
without investing tons of money in hardware.

With Rebirth, you can create looping music for Stream or Event sounds in Flash. You

can also create some weird effects by tweaking the various knobs and adding distortion.
Prepare yourself to spend long hours and sleepless nights experimenting with this program.
That's not to say that it's extremely difficult — it’s not. Rebirth is actually quite easy to get
the hang of, but you’ll soon be keeping the neighbors awake at night with heavy bass and
spacey frequencies.

Rebirth emulates two synthesizers, Roland 303s, and two drum machines, a Roland 808
and a Roland 909. Countless Mods (modifications) are available on the Internet, with dif-
ferent graphics and sample sets. Some of these sample sets specialize in certain types of
electronic music, such as drum and bass, dub, industrial, and so on. For the purposes of this
tutorial, however, we use the default Mod, which has controls that are easy to use (and
that provide that sought-after 1980s Electro sound.)

Getting started with Rebirth

First, familiarize yourself with some of the Rebirth controls. Refer to Figure 39-13 for

the main Rebirth window. This interface offers a fair number of different audio control
options, and the Rebirth manual describes them very well. You should have a basic knowl-
edge of Rebirth for the purposes of this tutorial. When you open Rebirth, you see the
main interface shown in Figure 39-13.

Although you can use the demo version of this software for the purposes of this tutorial, it
lacks the capability to save any final audio files and shuts down after 15 minutes.
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Figure 39-13: The main Rebirth window

Creating your first simple beat in Rebirth

In Pattern Mode, press Play and look at the 909 at the bottom of the screen. You'll notice
red lights moving from left to right over the 16 step buttons. This represents one musical
measure. To modify the beat that is playing, you can clear some or all of the buttons and
add your own. You can also select pre-made beats by pressing the pattern buttons on the
left side of the screen.

To clear an entire pattern, move the red Focus Bar down to the bottom of the screen using
the down-arrow key and then choose Edit=> Clear.

To begin creating your own beat, or to modify an existing one, you will want to “solo” the
909, so the other sections don’t get in the way. To do this, click the Mix buttons to turn
off the green lights in all but the 909 section. You should now only hear the 909. You can
also select the number of beats per minute by altering the number on the BPM selector at
the top left of the screen.

More advanced musicians may want to change the time signature by altering the number
in the value display on the left side of the 909 (see Figure 39-14). When you change the
number, you're altering the total of sixteenth notes within a bar. Thus, if you change it to
14, there will be 14 sixteenth notes between the beginning and end of a bar.
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Figure 39-14: The 909 is “soloed” in the main Rebirth window.

To select different drum sounds to play, you can either use the rotary dial on the right
side, or you can click the sound names above the 16 step buttons. Each step button
also has two instance levels. The first time that you click a step button, a faint red light
appears, indicating a lighter drum hit. The second time that you click the same step but-
ton, the heavier red light appears, indicating a heavier hit. The third time that you click
the same button, you clear it. No sound is produced.

The 909 also has a Flam feature that simulates the sound of a percussionist hitting a drum
with both sticks at slightly different intervals (see Figure 39-15). To use this feature, click
the Flam button on the 909 and choose the step button that you want to hear the Flam
on. The dial above the Flam button adjusts the “width” of the Flam — the actual time
interval between the two simulated “stick hits.”
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Figure 39-15: This figure shows the various instance
levels of the 909.

The faint light in Figure 39-15 indicates a “light hit.” The heavier one indicates a “heavy
hit.” The green light indicates a “Flam,” which is similar to the sound of a drummer hitting
a drum with both sticks at slightly different intervals.

The process of creating your own beat involves clearing all or some of an existing drum
pattern by manually clicking the step buttons for the various drum sounds and then click-
ing in new ones. After you've found a suitable bar of beats, at a suitable speed, you're
ready to add some 303 synthesizer.



Chapter 39 + Working with Audio Applications

Adding sound from the 303

The two top sections are digital replications of the vintage Roland TB 303 analog synthe-
sizer. These are a little bit more difficult to program than the 808s, and those new to
Rebirth may find it a little frustrating. A good way to begin is to customize an existing
pattern.

Use the up-arrow keys to move the focus bar to the 303 that you want to use. Solo it the
same way that you solo the 808 (forthcoming). Press play, and begin the process of choos-
ing a pattern.

You can choose the pattern, either by using the Pattern Selector on the left side of the
303 (see Figure 39-16), or by pressing Ctrl+R to randomly surf the patterns. After you find
a suitable pattern, you can begin to modify it using the synthesizer sound controls.
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Figure 39-16: The various synthesizer
sound controls on the 303

The synthesizer sound controls can create interesting results. For a detailed description of
what each control does, consult the Rebirth manual. Keep in mind that experimentation
is key. Set aside some time to create the perfect synthesizer lick by playing with these
controls.

Using the 808

The 808 drum section, above the 909, is similar to the 909, but with several differences.
For one, the drum sounds are different. Also, the controls aren’t quite the same. When
you are creating or editing beats in the 808, you only have one instance level on the key
buttons. The 808 uses instead the Accent (AC) feature to create heavier beats. The Accent
feature is located over the first key button, and when selected, this allows you to add
accents just like you would add a sound or beat. When you add an accent to a key button,
all other sounds that occur on the same key button are emphasized.

Other controls in Rebirth

Other effects and controls in Rebirth can help you find the sound you're looking for. Here
are some of the basic ones:

+ Distortion (Dist): Distortion is an effect similar to cranking up a guitar amplifier
to full volume. It creates a harsher, louder sound. Clicking the Dist button on the
right side of any of the four sections applies Distortion. Although distortion can be
applied to any or all of the sections at the same time, only one master control exists
for all sections. It is located on the right side of the Rebirth window.

4 Pattern Controlled Filter (PCF): The PCF is a versatile filter that can be applied
to one section at a time. It has a master control on the right side of the Rebirth
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window. The PCF radically modifies the sound, essentially by reshaping it. To experi-
ment with the PCF controls, move the four slider bars up and down.

+ Compressor (Comp): The Compressor evens up the audio signal, making it sound
tighter. You can use the Compressor for one individual section or for the Master
Output.

4+ Delay: The Delay creates an echo effect for a given sound. You'll find delay knobs
on the right side of each section and one master control on the right side of the
Rebirth window.

4+ Level Controls: You can control the sound levels that are going out to mix by
using the mix slides to the right of each section. Remember that as discussed earlier
in this chapter, Levels are important to consider before you import your final sound
or music loop into Flash. A Master Output slide also exists that controls the Levels
going out. Make sure that the meter isn’t spending too much time in the red, or
clipping will occur.

Preparation, mixing, and exporting Rebirth loops

At this point you should have a loop created that you want to export to AIF or WAV for-
mat. Before you do the final export, you should take a few steps to ensure good quality
output.

+ Final Mixing: Make sure that all the sections you want to mix are no longer
soloed. To do this, make sure that all of your sections are set to go to the mix (green
light on). Set the Levels on your sections individually to your liking by adjusting the
Level Controls, as described previously. Bring them down if they are too hot (too
much in the red), and set the Master Output Levels in a similar way.

4 Switch to Song Mode: To export your Rebirth loop to AIFF or WAV, you need to
switch to Song Mode. To do this, click Song Mode at the top of the application
window. In Song Mode, choose Edit=> Initialize Song from Pattern Mode. Press Play
to test your loop.

4 Exporting: To export your loop, choose File = Export Loop as Audio File. You’ll be
given the option to save your loop as a WAV or AlF file. The quality is automatically
set to 44.1 kHz, 16-bit.

You should now have a one bar loop in AIF or WAV format. You can test it in another
audio application, such as Peak or Sound Forge, and make any necessary changes, add
additional effects, or import it directly into Flash.

Once you get the basics down, you will no doubt want to work on more-complex sounds.
Creating a one-bar loop in Rebirth is just the beginning —you can use the Rebirth record-
ing and loop features to make complex songs. Rebirth can also be integrated with other
audio applications, such as Cubase VST. For more information on how to create a more-
complex sound in Rebirth, refer to the very comprehensive Rebirth manual.
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With the greatly improved MP3 compression available since Flash 5 and new MP3 import
abilities in Flash MX, an incentive now exists to create complex, high-quality electronic
music by using an application, such as Rebirth, without having to worry as much about file
size. And the rewards for creating your own samples, loops, and songs are tremendous.

Rebirth is available for Macintosh and Windows platforms. You can download a demo
version of Rebirth from the Propellerhead Web site at www.propellerheads.se/demo.
You can also find information about Rebirth at www.steinberg.net.

ACID Loops to and from Flash

As in any creative field, there are certain basic guidelines for audio editing. At the same time,
any truly creative person knows that creative ideas often come out of breaking these guide-
lines. This tutorial only presents some basic ideas to follow if you're looking for a starting
point in using Sonic Foundry’s ACID to make sound loops for use in Flash. The tutorial also
assumes that you have at least beginner-level experience with ACID —you’ll need to know
how to use the basic ACID tools and must be familiar with the faders, tempo, and pitch
functions.

About the library disks

Sonic Foundry ACID software comes with a disk titled Essential Sounds vol. 1. This disk
contains enough loops to keep you busy for quite some time. You can purchase additional
disks from Sonic Foundry. (For more information, check Sonic Foundry’s Web site at www .
sonicfoundry.com/acid.html).

Choosing the loops

Choosing the files for your loops is something everyone does differently. Although there is no
right or wrong way to arrange a song, there are a few things to keep in mind. Not everyone
has a subwoofer! If you decide to crank some serious bass and drums, be aware that it might
sound awful coming through a tiny set of built-in speakers. You can also lose many high fre-
quencies because of poor speakers.

Tempo and key changes

The tempo of a loop is up to the creator. However, some loops might seem to drag or speed
up when played with other loops. Loops are usually best when placed within a limited range
of beats per minute (BPM) above and below their original tempo. If the loop is pushed out-
side this range, it can lead to bad sound. Although there is no set rule for this threshold, it
helps to know the original tempo when you are pushing a sound in this manner. Tempo is
listed on the general ACID interface. The original tempo of a loop can also be found in the
Properties dialog box. Just right-click/Control+click the file and choose Properties from the
contextual menu. Speeding up and slowing down a loop will bring out human errors that
aren’t easily noticed at the original tempo. Don’t assume that all Sonic Foundry loops are cut
precisely either! Again, your ear is the best judge. As for key change, just be sure that you
change all the tracks if you change one track. Otherwise, this might result in some disharmo-
nious music. Yet, if that’s your thing, by all means experiment.
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. .
Mixing

The key to mixing in ACID, or any environment, is consistency. Because each loop was proba-
bly recorded in a different environment, you will want to mix all the tracks smoothly to make
it sound as if they were all playing together. Also, a combination of like instruments (such as
four tracks of drums or two bass tracks) can lead to an overload in one particular frequency
or a muddy mix. When mixing, test at least three different levels. If you only mix with your
speakers cranked all the way up to 10, you will be inconsistent with the same mix at a lower
level. Try to find a mix that sounds equally good at low, medium, and loud volume. This
ensures that the listener has a pleasant experience with whatever speaker setting they’re
using.

-
Exporting
When you've finished mixing your loop, you can export it in a number of different formats.
Make sure that your loop region is marked at the beginning and end of the selection you want
to export. (To be safe, you may choose to erase all existing audio outside of the loop region.)
From the File menu choose Save as and check the option to Save only the audio within the
current loop region. The drop-down menu to the right of your new filename will give you a
number of combinations for sample rates in both WAV and AIFF formats. Save your file to a
new name (to avoid overwriting your original file) and then import the loop into the Flash
Library.

Summary

4 Remember the order in which the optimization process should follow: 1) Edit audio,
2) Normalize, 3) Convert to mono, 4) Resample.

4+ Always start with the highest quality audio possible. While it may be easy to reduce
quality and file size, it is extremely hard to increase quality on an already poor file.

4 Choosing a sound card appropriate for your project needs and paying attention to the
output of your recorded audio are the best ways to ensure control over your final sound
quality. The speakers on which you listen to your recorded audio can be just as impor-
tant as the preamps and sound card you use to maintain that great sound quality. Shop
around, talk to people with experience, and try to test equipment before buying it.

4 Adding a small fade to the beginning and ending of loops can help remove unwanted
skips and clips to your event loops in Flash. Make sure that the fade does not occur
over too long of a gap, or the loop will appear to drop.

4 Use programs like Propellerhead’s Rebirth and Sonic Foundary’s ACID to create your
own custom loops and sound effects.

4+ Always save a backup copy of your original sound file. This is key in checking two files
against each other, matching and comparing file sizes, as well as giving you a great
place for starting over when you completely mess up!
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